Erstellung einer FAQ

Dieses Thema im Forum "Modifikationen - Allgemeines" wurde erstellt von Morywen, 23. Mai 2019.

  1. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    Kurzes Update: Nicht die PI hat einen Fehler, sondern dieser Lag bei mir. Da die Janmod sich problemlos installieren ließ, habe ich dann mal die nächste angeschaut. Korgans Erlösung wurde vor einigen Wochen fit für die Pi gemacht, dabei auch die tp2 von Korgan.tp2 in korgan.tp2 umbenannt. Bei entpacken der Zip wurden beide beibehalten und befanden sich im entsprechenden Modordner. Da wusste die WeiDu wohl nicht so recht, welche sie denn nun nehmen sollte. Darüber hat sich da Programm wohl aufgehangen. Ohne Fehlermeldung ist es mir auch nicht so schnell klargeworden. Es lehrt mich etwas aufmerksamer beim Updaten der Mods zu sein und genauer hinzuschauen, was die PI einem so an Mods zeigt. In den letzten Tagen hatte ich mit einer C&P Liste gearbeitet und mich um die Anzeigen nicht weiter gekümmert. Also dumme Frage von dummen User, immerhin ist es geklärt.
     
  2. Dabus

    Dabus Senior Member

    Registriert seit:
    Nov. 2007
    Beiträge:
    5.048
    Zustimmungen:
    3
    Meinst Du das da etwas weiter unten von Gwendolyne? Also mit doppelten Mod-Versionen im Download-Ordner? Heißt das, das PI erst dann auf die Nase fällt, wenn es los legen soll und nicht vorher? Wäre ja von der Abfolge her etwas doof.

    Oder meinst Du, PI erkennt die Weidu-Setups bei Dir nicht mehr, weil etwas groß oder klein geschrieben wird? Bei den Skript- und wenigen Programmiersprachen die ich gesehen habe, muss man es eher explizit aktivieren. Da PI für Windows Umgebungen geschrieben wurde (klar, .net Core gibt es auch für andere Systeme wie Linux und Mac), wäre es dem Dateisystem von Windows auch egal. Weidu kümmert es offenbar auch nicht, ob Du eine setup-janquest.tp2 mit einem Setup-JanQuest.exe-Weidu Setup zusammen bringen willst.

    Ich habe auch mal testweise mit Visual Studio Oberfläche ein c# Programm "zusammen geschoben" und beim Klick auf einen Knopf den Start von einem Programm definiert. Dabei habe ich in dem VS eine andere Kombination wie beim Namen der TP2 / der EXE genommen. Dem System ist das ganz egal und hat trotzdem das Setup gestartet und es hat alles gefunden.

    Da würde ich Dir nicht die Schuld in die Schuhe schieben. Kommt natürlich drauf an, wie Alien PI geschrieben hat, aber das wäre das erste, was mir zum Starten von Prozessen und Warten auf Antwort über den Weg gelaufen ist. Kann natürlich sein, daß da was anderes / mehr gemacht wird.
     

    Anhänge:

    • Test.png
      Test.png
      Dateigröße:
      50,6 KB
      Aufrufe:
      2
    Zuletzt bearbeitet: 17. Mai 2020
  3. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    Das Problem war hier eher, dass die PI die beiden tp2 nicht als Duplikat erkennt und mir keinen Hinweis gab. Bevor Gwendolyne die Korgan Mod geupdatet hatte, hieß die tp2 Korgan.tp2. Danach korgan.tp2. Die PI hält dies wohl für zwei unterschiedlichen Mods, denn sie zeigt beide untereinander an. Da ich schon eine Installationssequenz für den Test hatte, habe ich die Installation gestartet, und es gab keine Fehlermeldung. Nach der Installation der JanQuest Mod, bleibt die PI hängen. Wenn ich die ältere großgeschriebene tp2 entferne, funktioniert die Installation. Eine der beiden Programme PI oder WeiDu weiß nicht welche tp2 nun zu verwenden ist. Was ich nicht ausprobiert habe ist, was passiert, wenn ich es von Hand installiere. Das müsste ich noch testen.
     
  4. Dabus

    Dabus Senior Member

    Registriert seit:
    Nov. 2007
    Beiträge:
    5.048
    Zustimmungen:
    3
    Auch wenn Du sicher keine Grundsatzdiskussion starten wolltest: Das Windows Filesystem erlaubt zwar zwei Dateien im gleichen Ordner, die sich nur durch die Groß/Kleinschreibung unterscheiden, aber das muss man erst erlauben (Das geht z.B: so). Sonst geht das per Standard unter Windows nicht (siehe Screenshot).

    Wenn Du da mal daran (un)bewusst "hantiert" hast, dann könnte das bei Dir durchaus sein, ist aber eher nicht normal. Zumindest hätte ich bis eben auch behauptet, daß Windows das nicht kann. Das kann man überprüfen, indem man z.B. auf das Beispiel aus meinem Screenshot fsutil file queryCaseSensitiveInfo C:\Users\user absetzt. Bei mir kommt dann Das Attribut für Groß-/Kleinschreibung für das Verzeichnis "C:\Users\user" ist deaktiviert..

    Wenn Du so was hättest, wärst Du also vermutlich aus IT-Sicht ein "Sonderfall". ;)

    Ich kann mir auch vorstellen, daß man bei bestimmten UAC-Konstellationen Daten, die Sachen im %localappdata%\VirtualStore statt im eigentlichen Ordner ablegen, für den Benutzer weniger lustige Konstellationen erzeugen kann. Das liegt dann aber daran, daß das Windows die Daten aus dem VirtualStore dazu rechnet.
     

    Anhänge:

    • Test.png
      Test.png
      Dateigröße:
      28,8 KB
      Aufrufe:
      3
    Zuletzt bearbeitet: 18. Mai 2020
  5. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    Das ist sehr merkwürdig. Ich muss mal sehen, woran das liegt. Ich bin mir sicher, dies nicht eingestellt zu haben. Ich sehe mir das mal an.
     
  6. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    Gestern habe ich wieder eine Testinstallation laufen gehabt, die acht Stunden gebraucht hat. Das Ergebnis ist semizufriedenstellend. Also der Hänger zwischen Jans Quest und Korgans Erlösung bleibt bestehen, auch ohne zweite TP2. Warum es da an der Stelle in einer größeren Installation hakt, kann ich nicht erkennen.
    @Dabus Wer lesen kann, ist echt im Vorteil. Ich war total betriebsblind und haben übersehen, dass sich vor der der älteren Korgan Tp2 ein setup befand. Also eine tp2 hieß setup-Korgan.tp2, die andere nur korgan.tp2. Was die PI da zum stottern bringt, ist mir immer noch ein Rätsel. Die Jan Quest wird nach Log erfolgreich installiert und dann bleibt die Installation hängen.
    Dann tritt das Phänomen auf, dass nach jeder Mod die Meldung kommt:IndiNPC/Tra/German/setup.tra file not found. Skipping... Das könnte natürlich an manchen Stellen auch zu Problemen führen. Einige Mods wurden wegen anderer Probleme nicht installiert.
    Bei Brandock kam die PI mit WeiDu ins Land of Confusion, von Hand lässt sich die Mod völlig normal installieren.
    Bei Stratagems wurde die Komponente zu Einleitung der KI nicht installiert, weil folgende Fehlermeldung kommt:
    ERROR: Failure("You are trying to edit CLERIC_IMPERVIOUS_SANCTITY_OF_MIND.SPL, which does not exist in the game")
    Wahrscheinlich liegt eine Inkompatibilität mit irgendeiner anderen Mod vor, die daran etwas geändert hat, aber dazu muss ich dann mal die Read mes studieren, um diese zu finden. Wenn jemand eine Idee hat, gerne melden.
    Immerhin ist die Installation mit einigen kleineren Hängern sonst durch gelaufen und beide Teile des Spiels starten und stürzen nicht sofort ab. Ich werden unter der Woche mal sehen, die Debugs studieren und versuchen einige Fehler zu beheben. Vor allen die Mod herausfischen, die bei Stratagems dazwischen funkt.
     
  7. Jastey

    Jastey Matron Modderholic

    Registriert seit:
    Mai 2004
    Beiträge:
    7.670
    Zustimmungen:
    182
    Die genaue Fehlermeldung bei Brandock würde mich interessieren, allerdings glaube ich nicht, dass ich direkt was helfen kann.
    @Morywen es kann durchaus sinnvoll sein, ALIEN Rückmeldungen zu geben. Die PI ist ja auch noch nicht ausgereift.z.B. das mit der setup-korgan.tp2 und korgan.tp2, da sollte die PI eine Fehlerneldung geben und nachfragen und nicht sich irgendwie aufhängen.
    Wenn ich Meldungen an ihn weiterleiten soll dann sag bescheid, dann bräuchte ich die Beschreibung so detailliert wie möglich plus Wortlaut der Fehlermeldung.
     
  8. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    @Jastey Das Aufhängen liegt leider nicht an der doppelten tp2, denn dieses mögliche Problem habe ich natürlich behoben. Das Problem ist, dass es keine Fehlermeldung gibt. Die Jan Quest wird als erfolgreich installiert deklariert, das steht auch so im PI Log und auch im entsprechenden WeiDu.log im BG2 Ordner. Nur tut sich danach nichts mehr, es kommt keine Fehlermeldung. Wenn man auf Pause drückt erscheint ein Waiting for finish... und wenn man Unpause macht, passiert auch nichts mehr. Ich werde mal mit einer kleineren Auswahl etwas testen, was passiert. Es würde ja vielleicht schon helfen herauszufinden, welche Mod das Problem nun macht.
    Bei Brandock meldet die PI einen tp2 error. Die WeiDu gibt, wenn sie irgendetwas nicht richtig deuten kann, irgendeine Meldung mit Land of Confusion aus. Das Log in der PI zeigt leider nur die letzte Meldung, die da keinen Aufschluß gibt. Wenn ich die nächste Installation laufen lassen und der Fehler wieder auftritt, kopiere ich die Meldung direkt raus. Von Hand ließ er sich reibungslos installieren. Vielleicht ist es auch die direkte Reihenfolge der beiden Mods, die irgendwie inkompatiebel ist. Ich habe eine andere Installation aus dem letzten Jahr, wo beide Mod ohne Hänger installiert wurden, allerdings nicht direkt hintereinander.
     
  9. Acifer

    Acifer Senior Member

    Registriert seit:
    Apr. 2019
    Beiträge:
    758
    Zustimmungen:
    52
    Ich wollte mich hier einmal ganz herzlich bedanken, weil ich gestern mit Hilfe dieser tollen FAQ in ganz kurzer Zeit eine voll lauffähige BGT-Installation aufgestellt habe. Danke für die ausführlichen Erläuterungen! :up:
    Eine Frage zu den "zu lauten" BG1-Soundsets habe ich noch:
    Wo finde ich diese in den FAQ erwähnte Mod?
     
  10. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    @Acifer Vielen Dank!
    Gibt es die nicht auf ShS? Ich muss gestehen, dass ich die Mod seit ewigen Zeiten auf einer Festplatte rumliegen habe. Meine Sammlung ist inzwischen recht groß, und wenn Mods nicht geupdatet werden, nutze ich diese Versionen. Ich könnte mal in der BWP schauen, wo da hin verlinkt wurde. Das kann allerdings etwas dauern.
     
  11. Dabus

    Dabus Senior Member

    Registriert seit:
    Nov. 2007
    Beiträge:
    5.048
    Zustimmungen:
    3
    Ja, ist genau da.
     
  12. Acifer

    Acifer Senior Member

    Registriert seit:
    Apr. 2019
    Beiträge:
    758
    Zustimmungen:
    52
    Vielen Dank!

    @Morywen: Möchtest Du diesen Link vorne mit verlinken? Bei mir hat die Suche mit Google nach dieser Mod und auch die Suche bei SHS / G3 leider keine direkten Treffer gebracht.
     
  13. Morywen

    Morywen Senior Member

    Registriert seit:
    Okt. 2017
    Beiträge:
    897
    Zustimmungen:
    87
    @Acifer Werde ich bei Gelegenheit machen. Ich muss mir eine Liste machen.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden