[IWD2] Fehlermeldung nach Mod Installation

Dieses Thema im Forum "Icewind Dale" wurde erstellt von Lord Nathan, 13. Februar 2015.

  1. Lord Nathan

    Lord Nathan Junior Member

    Registriert seit:
    Okt. 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Ich habe folgendes Problem:
    Ich habe vor ein paar Tagen die Mod "Icewind Gate II" installiert. Als ich das Spiel danach starten wollte kam diese Fehlermeldung:
    "An Assertion failed in ChTlkTbl.cpp at line number 90".
    Ich habe danach so einiges ausprobiert, doch selbst eine Neuinsallation des Spiels half da nicht.

    Kann mir jemand helfen?
     
  2. Dabus

    Dabus Senior Member

    Registriert seit:
    Nov. 2007
    Beiträge:
    5.030
    Zustimmungen:
    3
    Was ist denn bei Dir eine Neuinstallation? Wenn alles mit den Original-Daten ersetzt wird, sollte es eigentlich passen. Das einzige wäre wohl: Hast Du die Überreste nach de Deinstallation entfernt? Oder lagen da noch ein paar Dateien herum, die beim erneuten Installieren von IWD vielleicht nicht ersetzt werden konnten? Oder schwirrt da Zeugs im Override und Data herum, der einfach keinen Bezug zum normalen Spiel hat?

    Und das übliche: Hast Du die Pfade korrekt in der Alias-Sektion der IWDII.ini stehen? Wenn die nicht zum Spielpfad passen, passieren komische Sachen.
     
    Zuletzt bearbeitet: 13. Februar 2015
  3. Lord Nathan

    Lord Nathan Junior Member

    Registriert seit:
    Okt. 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Ich habe alles entfernt und in den einzelnen Ordnern kann ich nichts Verdächtiges erkennen.
     
  4. White Agnus

    White Agnus Senior Member

    Registriert seit:
    Sep. 2008
    Beiträge:
    5.088
    Zustimmungen:
    0
    Hmm, habs gerade hochgezogen und bei mir kommts zu keinen Problemen...

    Hast du irgendwelche Mods installiert (also unter BG2, oder unter IWD2)?
    Um das ganze lauffähig zu bekommen, muss BG2 + ToB mit Patch 26498 sowie dem originalen BaldurDash installiert sein, sowie IWD2 + Patch 201, alles andere ist nicht getestet. ;)

    Zum Installieren sollte man frischinstallierte Versionen nutzen, da selbst nach dem Deinstallieren von Mods noch Files zurückbleiben könnten, bzw. die Dialog.tlk die Strings der Mods behält... ;)

    Weiterhin sollte man vielleicht die README beachten:

    Und ne Beta wirds solange bleiben bis sich dem ganzen einer annimmt (was wohl keiner mehr versuchen wird, höchstens IWD2:EE kommt irgendwann raus. :D)

    Das Ding zu spielen würd ich keinem empfehlen, da es in allen Punkten buggy ist (so ne einfache Konvertierung von AD&D nach D&D3.0 macht man nicht eben an nem Wochenende... ;))
     
  5. Lord Nathan

    Lord Nathan Junior Member

    Registriert seit:
    Okt. 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Es kann sein, dass ich bei der Mod-Installation noch andere Mods bei BG2 hatte - nur was ich nicht verstehe: eigendlich sollte dieses Problem doch bei einer Neuinstallation von IWD2 behoben sein, oder nicht?
     
  6. White Agnus

    White Agnus Senior Member

    Registriert seit:
    Sep. 2008
    Beiträge:
    5.088
    Zustimmungen:
    0
    Hmm, du importierst BG2 nach IWD2, wenn du BG2 also verändert hast (durch Mods oder was auch immer), der Mod IWG aber diese Änderungen nicht erwartet, kann es zu Fehlern bei der Installation und zu Abstürzen kommen...

    Es hilft also nichts immer nur IWD2 neu zu installieren, du solltest das zu importierende Spiel BG2 mal neu installieren. ;)

    Vielleicht mal hier ne Anleitung, wie du vorgehen solltest:

    1) BG2 Installieren (Vollinstallation)
    2) ToB Installieren (Vollinstallation)
    3) Letzten Patch installieren (v26498)

    (Wenn du die GoG Version hast, brauchst du nur BG2 - Complete installieren, bei der DnDMC nur die Lost Files entpacken)

    4) BaldurDash installieren (nur die verlinkte Version, nicht die WeiDU Variante!)
    5) IcewindDale II installieren (Vollinstallation)
    6) Letzten Patch installieren (v2.01)

    (GoG Version ist schon gepatcht, DnDMC die LostFiles nutzen ;))
    7) Beide Spiele anspielen
    8) IWG2 Delta 1 in dein IWD2 Verzeichnis entpacken (ist spielbarer als die Beta von Weimer)
    9) configuration im entpackten IWG2 Ordner öffnen und Pfade (also source und target) auf deine Installationen anpassen und speichern:

    Code:
    ~source~         [ ~[COLOR="Lime"]D:\IWG\BG2[/COLOR]~ ]
    ~source.variant~ [ ~BG2~ ]
    
    ~target~         [ ~[COLOR="lime"]D:\IWG\IWD2[/COLOR]~ ]
    ~target.variant~ [ ~IWD2~ ] 
    10) Install-IWG2.bat ausführen und warten bis alles fertig ist ;)

    Achja zusätzlich vielleicht noch die Notes von Weimer, was NPCs angeht:

     
    Zuletzt von einem Moderator bearbeitet: 14. Februar 2015
  7. Lord Nathan

    Lord Nathan Junior Member

    Registriert seit:
    Okt. 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Ich habe alles installiert, doch der Fehler kommt immernoch. Selbst ohne, dass ich Icewind Gate II installiert habe.
     
  8. White Agnus

    White Agnus Senior Member

    Registriert seit:
    Sep. 2008
    Beiträge:
    5.088
    Zustimmungen:
    0
    Hmm, dann liegts also an IWD2...

    Welche Version davon hast den? CD/DVD/GoG/DndMC? Hast du das Ding mal gestartet ohne den Patch zu installieren? Welches Betriebssystem hast du?

    Hmm, vielleicht liegts auch an der TLK, versuch mal die dialog.tlk und dialogf.tlk mit denen aus diesem Paket zu ersetzen: http://www.whiteagnus.de/downloads/DnDMC_IWD2_LostFiles.7z
     
    Zuletzt bearbeitet: 14. Februar 2015
  9. Lord Nathan

    Lord Nathan Junior Member

    Registriert seit:
    Okt. 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Ich spiele mit DnDMC, Win 7. Ich habe beides schonmal versucht - mit und ohne Patch, es hat aber beides nicht funktioniert. Mir dann noch auf gefallen, dass wenn ich den DaleKeeper2 gestartet habe, er zurückmeldete, dass er die tlk-Dateien nicht lesen konnte.
     
  10. White Agnus

    White Agnus Senior Member

    Registriert seit:
    Sep. 2008
    Beiträge:
    5.088
    Zustimmungen:
    0
    Hmm und hat das ersetzen der tlks was gebracht? :D
     
  11. Lord Nathan

    Lord Nathan Junior Member

    Registriert seit:
    Okt. 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Leider nein
     
  12. White Agnus

    White Agnus Senior Member

    Registriert seit:
    Sep. 2008
    Beiträge:
    5.088
    Zustimmungen:
    0
    Hmm, dann sinds nicht die tlks... (die hab ich selber im Einsatz und es läuft ohne Probleme...)

    Achja vielleicht hab ichs nicht gut genug erklärt, für die DnDMC braucht man keine Patches, die sind Up to Date, es fehlen nur ein paar Files.

    Versuch also mal DnDMC zu installieren und mach keine Patches, sondern nur die Lost Files drauf...
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden