[Installation] EET unter Linux funktioniert plötzlich nicht mehr

Dieses Thema im Forum "Modifikationen - Installation für Baldur's Gate Enhanced Edition" wurde erstellt von Armus Bergstein, 7. August 2018.

  1. Armus Bergstein

    Armus Bergstein Senior Member

    Registriert seit:
    März 2010
    Beiträge:
    284
    Zustimmungen:
    0
    Hallo,

    ich habe vor etwa einem halben Jahr eine EET Installation mit diversen Mods unter Linux erstellt (mit den GOG Versionen der Spiele). Ich habe dabei mehr oder weniger die Anleitung von Mumme hier im Forum befolgt. Das Spiel lief auch problemlos, selbst heute morgen noch. Dann habe ich mein Arch Linux geupdated und seitdem funktioniert es nicht mehr.

    Wenn ich das Spiel jetzt starte, lande ich in dem Auswahlbildschirm, wo man zwischen SoA, TDB und Black Pits 2 wählen kann. Dieser dürfte ja eigentlich nicht erscheinen. Wenn ich SoA auswähle, werden auch meine Spielestände angezeigt, aber wenn ich versuche einen zu laden, stürzt das Spiel einfach ab.

    Eine parallel installierte nicht modifizierte Version von BG2 läuft aber noch problemlos.

    Woran könnte das liegen? Benutzt irgendjemand anderes eine aktuelle Linuxdistribution mit EET und hat ähnliche Probleme?
     
  2. Mumme

    Mumme Verhüllter Enthüller

    Registriert seit:
    Mai 2003
    Beiträge:
    1.184
    Zustimmungen:
    1
    Ich habe die EET nie getestet. Ich halte es aber für unwahrscheinlich, dass es an dem Linux-update liegt, wenn die Standardversion noch läuft. Hattest du EET neu installiert nach dem update? Vielleicht liegt es an der aktuellen EET-Version, evtl. an nicht korrekt konvertierten Charset?
     
  3. Armus Bergstein

    Armus Bergstein Senior Member

    Registriert seit:
    März 2010
    Beiträge:
    284
    Zustimmungen:
    0
    Ich habe an der EET-Installation überhaupt nichts geändert. Die einzige Änderung war das Betriebssystemupdate. Ich habe das Update inzwischen auch wieder rückgängig gemacht, also alle upgedateten Pakete wieder in der alten Version installiert. Seitdem geht es auch wieder.

    Das Problem ist, dass bei dem Update über 460 Pakete betroffen waren. Da man bei Arch Linux aber keine teilweisen Updates machen kann, ohne sich möglicherweise das System kaputt zu machen, kann ich leider auch nicht testen, an welchem Paket das jetzt liegt. Am Kernel lag es zumindest nicht, den habe ich extra getestet.
     
  4. Mumme

    Mumme Verhüllter Enthüller

    Registriert seit:
    Mai 2003
    Beiträge:
    1.184
    Zustimmungen:
    1
    Hmmm, keine Ahnung. Kann ich auch nicht testen da ich noch Ubuntu 16.04 und keine EET installiert habe. Benötigt wird ciopfs und die folgenden Pakete:
    Requires the following packages to be installed:

    libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libjson-c2:i386 libopenal1:i386 libstdc++6:i386 libssl1.0.0:i386 libexpat1:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxcursor1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libjson0:i386

    Aber warum die Standardversion geht und EET nicht, ist mir schleierhaft.
     
  5. Armus Bergstein

    Armus Bergstein Senior Member

    Registriert seit:
    März 2010
    Beiträge:
    284
    Zustimmungen:
    0
    Danke für die Antwort. Ich vermute fast, dass es irgendwie mit ciopfs zusammenhängt. Vielleicht hat irgendetwas in dem Linux-update das Verhalten von ciopfs leicht verändert, so dass EET nicht mehr in der selben Weise funktioniert (auch wenn es keine Fehlermeldung gibt). Aber zumindest würde das erklären, wieso die Standardversion geht, denn da benutze ich ja kein ciopfs.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden