[Tutorial] Erstellung einer FAQ

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.109
Eventual hast Du die falsche lua editiert. Gibt es da nicht mehrere? Das Spiel arbeitet ja auch mit mehreren Stellen/Ordnern. Mir ist so hasl hätte ich dazu mal was gehört. Guck die von Dir editierte LUA nochmal an, sind die Änderungen noch drin oder hat sie sich geupstet?
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Ok, passt jetzt. Die Datei hatte irgendwie die Änderungen wieder verworfen. Ich vermute der Fehler war, dass ich die lua editiert habe, während das Spiel noch lief. Und er dann bei Beenden des Spiels die ursprüngliche lua wieder hergestellt hat.

Es gibt mehrere, man muss in der Engine.lua schauen, auf welchen Pfad das Spiel gesetzt ist und dort unter den "Dokumenten" dann die richtige baldur.lua editieren. Gerade wenn man mehrere Installationen am Laufen hat, muss jeweils in der engine.lua ein unterschiedlicher Pfad gesetzt werden und man darf das halt nicht verwechseln ;)
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.109
@Frankenheiner ich habe jetzt mal die von Dir gemeldeten Links der EET-Linkliste überarbeitet, danke nochmal. Links zu GitHub Releases habe ich mal drin gelassen, auch wenn es keine getaggten Releases gibt - das Repo hat man dann trotzdem, und vielleicht taggen die Modder später noch Releases. Die PPG BG1-Mods haben ihre Links alle auf derselben Seite, die sind etwas schwierig zu sehen aber das stimmt so. Ein link war in der Tat veraltet (Mystic irgendas kit). Die Direkt-Downloadlinks habe ich in Links zum GitHub Repo umgeändert, bis auf den Link zum polnischen Children of Bhaal Forum, da konnte ich keinen Link zur Downloadseite identifizieren.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.109
@Maus welche beiden Versionen?
Bei meiner Bemerkung zur EET-Linkliste ging es darum, den direkten Downloadlink de Mod "New travel system between Baldur's Gate City areas" zu Links zu einer Downloadseite zu verändern. Wenn möglich.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Oh, falsche Interpretation. Ich dachte du suchst den Link für die große Mod (Mysteries of the SwordCoast) in dem polnischen Forum. Das neue Reisesystem (oder ein neues Reisesystem) ist eine Komponente der Mod.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.109
@Maus Links dafür nur von EET-kompatiblen Modversionen. ;)
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Hm, falls jemand die Frage beantworten kann: was nimmt PI für die Installation? Immer die weidu.exe, die im Mod-Ordner liegt oder immer die aktuelle WeiDU, die bei PI selbst hinterlegt ist (irgendwie)?
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.638
Die PI bringt die neueste Version der WeiDu also 247 mit und schreibt die .exe Dateien der Mods selber. Zumindest habe ich das so verstanden.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Ok, das wäre schon mal ziemlich gut.

Erste Tests mit der PI waren allerdings ernüchternd. Der Download von Mods funktioniert schon mal nicht... die gesetzten Pfade in den Einstellungen werden nicht angezeigt in dem dafür vorgesehenen Fenster...
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.638
Hm, ich habe eben mal probiert. Von G3 funktionierten Framed und Kivan, Divine remix nicht.
Ich werde nächste Woche mal etwas damit herum spielen.
Bei den Pfaden weiß ich jetzt nicht genau, was du meinst. Da stehe ich etwas auf der Leitung.
Es ist halt noch beta und mit etlichen Haken und Ösen. Mich nervt es auch, wie lange es zum Teil dauert, bis man etwas unsortiert hat oder einen Haken gesetzt.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Hihi, ich habe gerade ein Video aufgenommen, bei dem ich illustrieren wollte, was genau das Problem ist. Und siehe da, es hat diesmal geklappt. Allerdings darf man den Pfaden in den Settings wohl nicht Falsches eingeben, sonst fliegt alles durcheinander. PI prüft da wohl, ob in dem Pfad tatsächlich das Spiel hinterlegt ist.

Aber bei den Downloads gibt es weiterhin eine Fehlermeldung. Sieht so aus, wie wenn der den Pfad nicht finden, in den diese installiert werden sollen.

Die Fehlermeldung sieht so aus:
Application: ProjectInfinity.exe
ApplicationLocalVersion: 0.9.6
ApplicationOnlineVersion: 0.9.7
ApplicationDirectory: D:\PI
OperatingSystem: Microsoft Windows NT 10.0.19042.0
NetFrameworkVersion: 4.8
PowershellVersion: 5.1.19041.1151
LanguageOrder: English
WeiDU version: 247.00
Git local version: 2.30.2.1
Git global version:
Reading web response completed. (Number of bytes read: 28)
Required Git 2.30.2 is missing
Test-Path : Cannot bind argument to parameter 'Path' because it is null.
At line:3138 char:28
+ if (Test-Path $path) {
+ ~~~~~
+ CategoryInfo : InvalidData: (:) [Test-Path], ParameterBindingVa
lidationException
+ FullyQualifiedErrorId : ParameterArgumentValidationErrorNullNotAllowed,M
icrosoft.PowerShell.Commands.TestPathCommand

Any local Git version is missing
Global Git is missing
 
Zuletzt bearbeitet:

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
So, beim nächsten Restart sind dann auch Downloads möglich. Irgendwie dauert die Konfiguration da immer sehr lange und man muss die PI wohl einige Mal neu starten, bis alles passt.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.638
Da gab es eine neue Version der PI, dann will das Programm ein Update und sollte theoretisch automatisch neu starten. Die Informationen sind zum Teil Recht kryptisch, obwohl es schon besser ist, als am Anfang. Die Reaktionszeiten sind auf meinem schon älteren Testlaptop zum Teil langsam. Da weiß ich nicht, ob es an der inzwischen sieben Jahre alten Hardware liegt. Obwohl die Installation eigentlich ordentlich schnell geht, und ich keinen großen Unterschiede zu meinem neueren feststellen kann.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Aber ein Problem hat die PI: ich kann Crossmod-Content in der Installationsreihenfolge nicht nach hinten verschieben. Und damit sind einige Mods nicht korrekt installierbar.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.638
Du kannst, wenn ich mich richtig erinnere, mit einem rechts Klick einzelne Modkomponenten in einen separaten Container werfen. Dieser erscheint ganz oben in der Rubrik und kann dann verschoben werden. Oder du wartest, bist du die Installationssequenz gesetzt hast und verschiebst die Komponenten dann dort an die richtige Stelle.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Hm, also einzelne Modkomponenten funktioniert nicht. Wenn ich die Komponenten anwähle und mit rechts-click extrahiere wird die komplette Mod geklont. Funktioniert zwar, weil ich dann ja nur eine Komponente auswähle, aber suboptimal. Andererseits wird diese Komponente schon aus der ursprünglichen Mod entfernt.

Noch eine Frage zu den Settings: wenn ich einfach meine BG1-Mod Version (die BG1-Mods sind schon installiert) als BG1EE+SoD eintrage und keine Mods für die BG1, dann müsste das doch funktionieren? PI nimmt die gemoddete BG1-Version und installiert dann die EET. Ich muss dann wohl noch per Hand bei der EET die compatibility ändern, aber so müsste es gehen, denke ich?

edit: und die PI merkt sich das nicht. Bei jedem Neustart kann man die Container neu erstellen. Wobei sich das blöde Ding gar nichts merkt. Die ganzen Auswahl-Haken muss man neu setzen.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.638
Wenn du die entsprechenden Mods in die Datei einträgst, kannst du eine schon gemoddetes BG1 EE nehmen, das ist kein Problem.
Alien hat irgendwo geschrieben, man könne da irgendetwas speichern. ich habe aber auch noch nicht rausgefunden, wie das geht. Sind die Container weg? Ich muss mir das nochmal genauer ansehen. Ich setze mir meist eine ISQ, die soweit enthält, was ich will. Danach kopiere ich mir das in eine Textdatei und kopiere dann in das Tool und schreibe neue Mods oder so von Hand rein. Da geht schneller als die Haken zu setzen. Das verschieben der Komponenten geht so auch schneller, zumindest ist das so mein Eindruck. Der Vorteil der PI ist halt, dass ich nicht ständig Mods hin und her kopieren muss. Auch die Installation ist bei vielen Mods bequemer, weil doch vieles ohne Zutun läuft. Aber so bequem wie dias BWS ist das PI noch lange nicht. Es ist halt eine Betaversion. Alien ist auch kein großer Freund von Dokumentation, er meint es wäre alles selbst erklärend. Nun ja, da er sich die Mühe in seiner Freizeit macht und das ganze schon hilfreich ist, akzeptiere ich da einfach so. Das Einarbeiten in das Tool braucht etwas Zeit.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.092
Ja, ich hab mal im Discord gefragt, da war dann auch die Antwort: lade einfach eine weidu.log hoch, das ist einfacher. Werde ich vllt auch mal machen. Spontan denke ich allerdings, dass ich im Moment zumindest mit der manuellen Installation schneller bin. Vor allem weil ja die Installation mit PI auch nicht ohne Interaktion ablaufen wird, weil ich bei der Installation ja dauernd Entscheidungen treffen muss. Und dann weiß ich zumindest bei den Abfragen, wo ich gerade bin ;)
 
Oben